Ibus

From noop linux
Jump to: navigation, search

Installation

You will need to install the ibus package.

For inital configuration, you should get this message:

IBus has been started! If you cannot use IBus, please add below lines in $HOME/.bashrc, and relogin your desktop.

export GTK_IM_MODULE=ibus

export XMODIFIERS=@im=ibus

export QT_IM_MODULE=ibus

Usage

There are currently 2 input methods available to use with ibus: anthy ( Japanese input ) and m17n.

To use m17n you will additionally need the packages: m17n-db m17n-lib ibus-m17n.